Instalo la pre-realse de buildcraft para la 1.2.3 con el modloader, también para la 1.2.3 y me sale que no son compatibles.
Sin embargo, si instalo modloader, too many items y explosive mod ba todo perfecto.

¿A que se deve el problema? lo e reinstalado unas 3 veces desde una versión de minecraft 1.2.3 sin modificar.

Los instalo con MC Parch, también compatible con la 1.2.3

También me pasaba con la 1.0.0 y la 1.1.0