Bueno tengo el siguiente problema, son varios la verdad y ojala haya algún experto en el tema que pueda echarme una mano debido a que soy novato en esto de los mods...

Primero que todo intenté hacerme un survival con mods, lo primero que siempre hago es intentar compatibilizar el forge y el optifine, pero siempre me daba crash, lo hice de muchas maneras e incluso de algunas absurdas, pegarlo directo en la carpeta mods, instalar ambos por separado ir a libraries-> optifine copiar el optifine y pegarlo en mods incluso unir los jar, hice muchas cosas y todas me daban crash, me descargué una .minecraft con ambos ''compatibilizados'' pero al poner un mod, por más simple que sea, el xaero's minimap ya me volvía a dar crash y tuve que dejar la versión.

En 1.7.2 simplemente al poner el optifine no abría el minecraft con launcher pirata (utilizo el shiginima para los mods) probé iniciarlo con el premium cargaba hasta el logo de mojang y luego crash (intentando compatibilizar el optifine y forge)

Ahora frustrado me decidí jugar en la 1.6.4, ya había jugado antes todo iba bien hasta que me decidí instalar el MCA (El comes alive) aparentemente ''todo iba bien'' hasta que me acerque a una entidad y si giraba un poco la cámara ya sea izquierda o derecha la entidad simplemente desaparecía, y si la volvía a poner donde estaba volvía a aparecer
no sé si es un fallo que ocasiona el mod puesto que ya antes había usado los mismos mods anteriormente y no pasaba esto, no solo ocurre con los del MCA si no también con entidades del minecraft vanilla, como sean zombies arañas esqueletos etc etc.

Si alguien pudiera echarme una mano con los problemas que tengo se lo agradecería mucho puesto que tengo ya dos días completos intentando echarme un survival cómodo pero siempre pasa algo.