Saludos, seguro más de uno habrá tenido el problema de incompatibilidad entre Java8 y Forge de la 1.7.2
La mayoría ofrece como solución instalar el Java7 pero a la larga, habrán otras aplicaciones que requerirán tenerlo actualizado. Así que aquí les ofrezco una solución que no implica desinstalar su Java8



Espero les sea de ayuda