ayuda con el mod MoreExplosives 1.6.2

hola amigos alguien me puede aiudar tengo el minecraft luncher con el forge y todo y instale el mod MOREEXPLOSIVE 1.6.2 y cuado me lo abria se me cuelgava y me sale este error algo del java relacionado con el bynari, pero ahora ni me abre el juego ayuda!

Prueva a descargarlo de [u][b]AQUÍ[/b][/u], si no te va, comprueba la compatibilidad de tus otros mods (Si son todos compatibles y el mod te sigue sin funcionar, entonces no sé que puede ocurrir)

ahora me acuerdo de l’error de Java era :Java™Plataform SE binary no responde : no se que es este error

Entonces no es problema del mod, sino de tu java, prueba a actualizarlo, es un error muy común.