Cargar mapas de versiones antiguas

Hola buenas a todos, en primer lugar quiero presentarme. Soy Wemento y hoy mismo me he unido a vuestra comunidad. Llevo enganchado a Minecraft desde las primeras versiones y quería formar parte de esta comunidad para aportar todo lo que sepa y para aprender de vosotros.

Bueno, vamos con la pregunta en cuestión, quería saber si existe alguna manera de poder cargar un mapa creado en versiones anteriores de Minecraft sin que suponga un conflicto con las que se usan ahora.
Personalmente el problema es el siguiente: yo tenia un mapa creado en 1.7.3 y al actualizar a las versiones actuales en su día quise abrir el mapa y no podía. Para abrirlo empecé a trastear quitando archivos y tal y finalmente conseguí abrirlo, pero con un problema: que una zona (concretamente la que quería visitar) está plagada de cubos y se queda pillado al estar ahí. El problema además es que una vez he entrado no puedo salir porque siempre que inicio el MC me da problemas nada más cargar el mapa (ya que renazco allí).

Estos son los archivos que he dejado para que me sea compatible pero sigo conservando los del 1.7.3. ¿Alguien sabe la manera de cargar el mapa sin perder información (que es lo que pasa cuando lo copio tal cual, que pierdo las últimas construcciones que hice)? Muchas gracias.

Captura.JPG

En principio no debería haberte dado problemas el cargar un mapa antiguo con las últimas versiones, ya que minecraft automáticamente convierte el mapa al nuevo formato, así que si te dio problemas es posible que el mapa ya traiga algún tipo de error. Asegúrate de que funciona perfectamente en la 1.7.3 sin ningún problema, ya que si tiene algún error con los chunks es posible que al hacer la conversión se corrompa completamente.

era un mapa de servidor, puede ser que eso influya?

Puede que,como dijiste, al ser de la versión BETA de Minecraft (1.7.3) no funcione con respecto a la versión alpha (actual) ya que, puede tener otro sistema (gráfico o yo que sé)
PD:Por ser un mapa de servidor no creo que no vaya a funcionar. Espero que te ayude.

y que debo hacer entonces para compatibilizarlo?

Hay herramientas por internet que te analizan el mapa y corrigen los errores. Estoy casi seguro que tienes algún chuck dañado. Esta erramienta te lo generaría de nuevo y ya te funcionaría.

Un saludo.

he estado buscando y no encuentro nada en concreto, sabes de algun nombre de esos programas para buscarlo directamente?
gracias de nuevo!