Modo LAN no funciona

Buenas a todos y feliz año.
Quería preguntar por aquí a ver si alguien entiende lo que me pasa con el minecraft en LAN.
Juego con amigos y tengo yo los datos de la partida y eso, y para jugar abro esc. pongo modo lan y lo activo. Me sale un número que es el puerto que tengo que abrir.

Abro ese puerto (ya he mirado mil veces que no me haya equivocado al abrirlo y no, está bien). Después miro cual es mi ip pública.
Y al final envío la ip pública y el nº de puerto a mis amigos y cuando intentan entrar no se pueden conectar.

No tengo ni idea de lo que pasa porque antes hacía lo mismo y me funcionaba.

Me ayudaría bastante que alguien me dijera que es lo que pasa.
Muchas gracias!

A ver… creo que estás mezclando conceptos… Si es una partida LAN no puede haber IP pública, será IP privada que te da el router y tus amigos deben estar en la misma red (en el mismo router). En caso contrario, ya no es una partida LAN, porque ya no estais en la misma LAN (que significa Local Area Network, red de área local)

Puede que mezcle conceptos, pero haciendo lo que he dicho si que se puede jugar en router distintos. Simplemente porque yo he podido, lo que pasa que ahora no.
Abriendo en LAN, si das la IP pública se puede jugar desde otras redes y si das la IP privada pues desde la misma. A mi me ha funcionado siempre hasta ahora, así que por eso pido ayuda.

disculpen las molestias pero que es el modo LAN no lo habia escuchado o quizas lo e hecho pero no sabia que es eso me podrian explicar muchas gracias.

Hostthegame