Necesito ayuda,con un servidor propio...

Pues bien os comento:

Hace una semana me descargue e instale un servidor de minecraft.net para jugar con unos amigos.
Abri el puerto correspondiente con la ayuda del servicio de ayuda informatica de mi compañia de internet.
Bien, los dos primeros dias el servidor funciono correctamente, estuvimos jugando etc… el tercer dia cuando lo encendi, yo me conectaba correctamente (con localHost) pero mis amigos con mi ip publica se conectaban y veian todo negro mienytras caian en el mapa, y aqui empieza mi quebradero de cabeza, primero con la compañia por si el router tenia algun conflicto de ip’s y efectivamente con lo que dejamos a mi pc (en el que esta el servidor) con una ip fija y la redireccion del puerto 25565. Y el caso es que ahora esta todo corecto el puerto esta bien, y de echo mis amigos si añaden el servidor lo ven bien con lo que me da a entender que tiene que ser algo de la configuracion del servidor, ya he probado de todo. Me baje un servidor bukkit y que creeis, me conecto con localHost y correcto pero a la hora de usar mi ip publica me pasa lo mismo, caes y ves todo negro… Y bueno no se, seguro que se me pasa alguna cosa, pero si me comentan hare lo que pueda, gracias de antemano al que se moleste.

2013-08-28_12.26.12.jpg Adjunto una imagen de lo que se ve cuando entras en el servidor desde la ip publica.

Por favor alguien que arroje un poco de luz a esto. Gracias !!

quedate quietoasta que agarre y si no funciona intenta iniciar sesion de servidor porque aveses se ocupa:D
porfavor entra en el sigiente link: EpicFreePrizes | FREE Rewards For Collecting Points asi me ayudaras a ganar minecraft premium y tu tambien podras ganarlo :slight_smile: fuentes:yo,yutube y epic free prises

Lo de quedarse quieto ya lo intente, y lo de iniciar sesion no te entiendo (login o register?), de todas formas creo que el problema no va por hay pero gracias.

Editado: ya probe a quedarme quieto todo el rato, al poco de llegar al bloque 0 me sale del servidor y me da este error: internal exception: java.net.sockettimeoutexception: read timed out

ReEditado: Desinstale java y borre todo lo reinstale y ahora entro en el servidor con la ip publica (con localhost bien) y me carga solo unos cuantos bloques del mapa. Al pasar como medio minuto o algo mas me echa fuera del servidor y me pone: conexion perdida Tiempo de espera agotado.