No puedo poner mods D:

Hola!

pues ultimamente eh querido ponerle mods a mi minecraft actualmente solo tengo el toomanyitems optifine y se supone tengo el modloader mi version es minecraft 1.2.5, bien, cuando pongo algun mod por ejemplo el craft guide o shelt mi minecraft colapsa (minecraft has crashed bla bla bla bla) y lo he intentado varias veces y no sirve por favor ayudenme que quiero ponerle el mod defosiles y arqueologia :DD

Hola.
¿Podrías decirnos qué es “blablablabla”? No te podemos ayudar si das tan poca información.
Hay algunos mods que no son compatibles entre ellos, y hay algunos mods que necesitan otras bases de mods.
¿Has eliminado Meta-Inf?
¿Has metido todas las bases que requieren esos mods? No se cuales necesitan, pero seguramente sean ModLoader y ModloaderMP. Las bases necesarias siempre están escritas en el post oficial del mod.

Si respondes esto, te podríamos ayudar.

La verdad es que es cierto que teneis cierta tendencia a omitir datos importantes a la hora de reportar un error. Los log de errores, aunque ininteligibles para la mayoría de usuarios comunes, contienen una buena cantidad de información bastante útil a la hora de depurar un error. Si no disponemos de esa información todo lo que te digamos será dar palos de ciego, porque hay múltiples motivos que pueden originar el error y sólo el programa, mediante ese log, nos puede decir qué es lo que falla, donde, cuando y como.

En resúmen, y tal y como Claper ha dicho, deberás postear el contenido del error para saber donde está el error.

intentare meter de nuevo el shelt y les copiare el informe de errores, si elimine meta-inf y cuando baje el shelt la pagina decia que necesitaba unicamente modloader el cual se lo meti y probe antes, si funciono

Mods loaded: 3
ModLoader 1.2.5
mod_TooManyItems 1.2.5 2012-04-13
mod_Shelf 1.2.5

  Minecraft has crashed!      
  ----------------------      

Minecraft has stopped running because it encountered a problem.

— BEGIN ERROR REPORT e1cac84a --------
Generated 20/05/12 19:38

Minecraft: Minecraft 1.2.5
OS: Windows XP (x86) version 5.1
Java: 1.6.0_32, Sun Microsystems Inc.
VM: Java HotSpot™ Client VM (mixed mode), Sun Microsystems Inc.
LWJGL: 2.4.2
OpenGL: Intel 945GM version 1.4.0 - Build 7.14.10.4926, Intel

java.util.FormatFlagsConversionMismatchException: Conversion = s, Flags =
at java.util.Formatter$FormatSpecifier.failMismatch(Unknown Source)
at java.util.Formatter$FormatSpecifier.checkBadFlags(Unknown Source)
at java.util.Formatter$FormatSpecifier.checkGeneral(Unknown Source)
at java.util.Formatter$FormatSpecifier.<init>(Unknown Source)
at java.util.Formatter.parse(Unknown Source)
at java.util.Formatter.format(Unknown Source)
at java.util.Formatter.format(Unknown Source)
at java.lang.String.format(Unknown Source)
at adn.a(SourceFile:142)
at cy.a(SourceFile:12)
at ModLoader.initStats(ModLoader.java:933)
at ModLoader.init(ModLoader.java:910)
at ModLoader.addAllRenderers(ModLoader.java:189)
at ahu.<init>(ahu.java:77)
at ahu.<clinit>(ahu.java:8)
at net.minecraft.client.Minecraft.a(SourceFile:273)
at net.minecraft.client.Minecraft.run(SourceFile:657)
at java.lang.Thread.run(Unknown Source)
— END ERROR REPORT e3b06984 ----------

esto es lo que me sale, espero me puedan ayudar (:

Incompatibilidad. En vez de tmi usa el nei a ver si con eso puedes solucionar eso.

NEI? disculpa mi ignorancia pero que es eso?

Ese error puede que tenga que ver con una instalación incorrecta de ModLoader… Consíguete un minecraft.jar limpio y reinstala ModLoader correctamente, o prueba a cargar sólo el cliente con ModLoader de manera dinámica en MagicLauncher y ver si sigues recibiendo el error.

Por cierto, NEI es esto:

[1.2.5 SMP] ChickenBones Mods - Minecraft Forum

si se puede ver en el informe de errores

Dos cosas más que puedes probar:

  1. Desactiva el mod_Shelf para ver si es problema de incompatibilidades.

  2. Asegúrate de no haber instalado o estar intentando ejecutar Java 7 de 64 bits (x64) porque estás rulando con un XP de 32 bits (x86). Eso también podría causar tu error.

Un saludo.

Por ciero, ¿ metes los archivos tambien en mods verdad?

esto es lo que tienes que hacer con el shelt

How to Install Shelves Shelf Mod for Minecraft 1.2.5
[ol]
[li]Download ModLoader[/li][li]Download Shelf Mod for Minecraft 1.2.5[/li][li]Open .minecraft / bin[/li][li]Open Minecraft.jar[/li][li]Delete META INF[/li][li]Drag mod loader files into Minecraft.jar[/li][li]Do the same with the shelve mod files[/li][li]Done![/li][/ol]

Aqui te dejo las url para que lo visites:

[1.2.5/12w19a] TooManyItems in-game invedit May 10 - Minecraft Forum

Shelf Mod for Minecraft 1.2.5

Risugami’s ModLoader for Minecraft Full Version 1.2.5

Si quieres usar en vez del TMI, El NEI ( similar al TMI para que nos entendamos )

Not Enough Items 1.2.5 Mod Minecraft 1.2.5 | Download Minecraft

ModLoaderMP 1.2.5 Mod Minecraft 1.2.5 | Download Minecraft

AdF.ly - shrink your URLs and get paid! ( Code intalar antes que el nei )

Hay le dejado el modloader que el shelt necesita, esta en la pagina oficial.

Me parece a mí que si no es capaz de instalar TMI tal cual difícilmente va a instalar NEI sin que su ordenador implosione, con el rollo del CodeChickenCore y demás, juas.

pues el minecraft funciona sin el shelf, osea solo funciona con el TMI, optifine y modloader si le pongo mas mods falla y donde puedo ver que java tengo? por que creo que lo actualize hace poco y en dado caso de que si tenga java 7 como lo quito? o que hago

Has intalado el shelt mal como yo sospechaba.

Instalalo como te dicho. con el modloader que te pide el autor

Si el juego te funciona bien con esos mods no es problema de Java así que puedes olvidarte de ello. Asegúrate de que instalas la versión correcta del mod que sea y ya está.

Otra cosa que merece la pena recordar: cuando sepas seguro qué mods vas a usar, hay que instalarlos en un orden más o menos establecido. Lo normal es esto:

  1. ModLoader
    (2. Opcional: ModloaderMP. Hay muchos mods que ya no lo piden)
  2. Minecraft Forge
  3. AudioMod
    (5. Si usas NEI: CodeChickenCore)
    (6. Si usas NEI: NotEnoughItems)
  4. XXX
  5. XX
  6. XXX
  7. OptiFine

Las XXX significan que puedes meter 20 mods o los que quieras en medio, pero se recomienda que SIEMPRE se instale OptiFine en último lugar para no romper nada y poder actualizarlo con facilidad. Al menos es la explicación de su creador, sp614x.

Esto es, obviamente, aplicable sólo a aquellos mods que HAN DE IR en el .jar. El resto los puedes meter en la carpeta /mods/ y a correr.

Un saludo.

no se que pasa no funciona ni siquiera poniendo solo el modloader y el shelf :/sigue saliendo lo de “minecraft has crashed” y el informe de errores

¿ Has utilizado el modloader que el autor pide expresamente?

te lo dejado hay atrás lo que tienes que utilizar.

Tengo exactamente el mismo problema , después de muchos intentos me di cuenta que se crashea únicamente con los mods que meten muevas cosas, como herramientas, bloques, crafts diferentes los que ya tiene el juego , espero haberme explicado bien y que también me puedan ayudar

Disculpa por haber usado tu post para pedir ayuda

Not Enough Items 1.2.5 Mod Minecraft 1.2.5 | Download Minecraft