Problema con mods.

Buenas a todos.
Tengo una duda, y es que no se si puedo tener un mod de una versión anterior anterior a la que tengo en el juego.
Por ejemplo: Tengo la versión 1.2.5 (por cierto, ¿es esta la última?) y me he descargado el mod Tropicraft, que es de la versión 1.0.0.
Instalé el modloader y el audiomod y me iba bien el juego, pero desde el momento en el que instalo este mod, al iniciar el juego y salir la ventana de mojang, me sale una ventana (informe de error) y se me cierra el juego al segundo.
Gracias de antemano :wink:

¿Y cual es el error?

Postea aquí el informe de error, si no, no te podemos decir cual es el problema, o si tiene solución.

Es que, como dije, la pantalla de error dura un segundo y no me da tiempo a ver lo que pone. Intenté hacerle un pantallazo, pero sale en negro la ventana del juego.

Ya, pero en la carpeta donde tienes el lanzador (Minecraft.exe), debería aparecer un archivo con el informe, si mal no lo recuerdo. Es que sin esa información es imposible saber cual es el problema.