Problema con mods

Hola buenas me he instalado el pack de mods de apocalipsis minecraft 4 para la version 1.7.10 y me deja entrer en el mapa i al pasar unos 5 minutos jugando se me cierra. espero que me puedan ayudar

Yo tengo un problema tambien relacionado con los mods, me instalé hace ya tiempo el launcher de ftb y empecé una partida en el pack de mods direwolf20 para la version de minecraft 1.6.4, el caso es que hace varios dias se me cerró repentinamente el minecraft y al abrirlo de nuevo todos los progresos que habia hecho hasta ese momento no se habian guardado, lo vi normal ya que se cerró repentinamente, pero esque me da ese problema todo el rato a partir de ese dia, no guarda los avances que hago y no se como solucionarlo. los nuevos mundos que creo van bien, pero ese en especial tiene mucho curro y me da pena eliminarlo. cualquier ayuda se agracede. tambien me valdria algún programa compatible con esta version y con los mods para pasar partes de mi mapa a otro. gracias^^

Therevenger yo tengo un server con ese mismo pack, si quieres jugamos!!
Hablame por skype: manu3243