Problemas con minecarts

Tengo un servidor con otra persona para jugar mediante hamachi, en la version 1.2.5.
El problema que tengo (que no he encontrado en ningún sitio), es que al colocar un minecart sobre los railes, este desaparece sin dejar rastro!!!
He entrado en servidores de otros amigos, y si usan minecarts, no los veo, de hecho, veo a su personaje sentado en el aire, pero no veo el minecart
¿Alguna idea?

Lo único que se me ocurre es que tu problema sea por el cliente. Pero vamos, poco más a raíz de la escasa información de la que disponemos.

Dinos todo lo relacionado a tu cliente. Sabemos que es la versión 1.2.5, pero no sabemos si es original o pirata, si usas mods o si usas algun texture pack y si te pasa o no en SP. Dinos también que GPU (tarjeta gráfica) usas, por si pudiera ser un error de corrupción gráfica. Es algo bastante extraño, pero podría darse el caso.

El cliente es descargado, no tengo el juego original. Mods me instalé el buildcraft y el industrialcraft, pero paquetes de texturas ninguno. En el modo un jugador, si que puedo ver las carretillas e interactuar con ellas, con lo que no creo que sea de la gráfica (una ATI Mobility Radeon HD 5470).
Y del servidor… pues no sé si será xq la persona con la que juego si que las ve e interactua con ellas.

Pues como no sea problema de lag, otra cosa si que no puede ser.

¿ en otros servers te pasa ? ¿ has probado ha entrar en ese sever con una copia limpia de minecraft ?

Solucionado, he probado con otra copia del juego, y ya. Conclusión: Cuidadín con lo que se descarga