Tengo problema con los mods

Cuando quiero añadir un mod me sale un error, pero si este mod lo quiero añadir solo lo ejecuta bien… que puede ser???
yo pienso que es incompatibilidad, pero vi en youtube algunas soluciones y los errores no son como los mios, sera el Launcher… la verdad ni idea, a ver si ven estas imagenes y alguien me ayuda a solucionar esto… me estoy volviendo loco…

Sin título.jpg
otro error que me encuentro es este

2.jpg

si alguien me puede ayudar diciendome en modo sencillo como solucionar esto se lo agradeceria…

el problema es con el mod Golem World

El golem world entra o es la causa del conflicto con otros mods, puede que no sean conocidos y por eso no están hechos para ser compatibles o directamente es imposible hacerlo, si recibes ese mensaje, lamentablemente en la versión en la que estas no hay manera de arreglarlo.

Fijate que los mods sean para tu versión…